ТутРешу.Ру

1) Найдите сумму натуральных нечетных чисел не превышающих n!

Задание:

1) Найдите сумму натуральных нечетных чисел не превышающих n! Это нужно сделать циклом for. 2) Составьте программу, которая производитсуммирование произвольного количества целых чисел вводимых с клавиатуры. Концом последовательности служит ввод отрицательного числа. Программу составьте двумя способами: использую цикл с предусловием и цикл с постусловием

Решение:

1) var n, i, s: integer; begin s: =0; readln (n); if n mod 2=0 then n: =n div 2 -1 else n: =n div 2; for i: =0 to n do begin s: =s+(1+2*i) end; write (s) end. 2) var a, s: integer; begin s: =0; read (a); while (a >=0) do begin s: =s+a; read (a) end; writeln; write (s) end. var a, s: integer; begin s: =0; a: =0; repeat s: =s+a; read (a) until a < 0; writeln; write (s) end.




Знаете другой ответ?

Отправить свой ответ