Задание:
1 задача: дан одновременный массив п целых чисел. Составить программу вычисления среднего арифмитичного четных чисел 2 задача: составьте программусокращения одновременного массива путем удаления каждого второго элемента
Решение:
var a: array [1… 100] of integer; n, i, count: integer; sum: real; begin read (n); for i: =1 to n do read (a[i]); sum: =0; count: =0; for i: =1 to n do if a[i] mod 2=0 then begin sum: =sum+a[i]; inc (count); end; writeln (sum / count); end. var a: array [1… 100] of integer; n, i, last: integer; begin read (n); for i: =1 to n do read (a[i]); last: =1; for i: =1 to n do if i mod 2=1 then begin a[last]: =a[i]; inc (last); end; for i: =1 to last — 1 do write (a[i], '); end. Примечание ко второй задаче: last — номер последней свободной ячейки.
Знаете другой ответ?