ТутРешу.Ру

Дан двумерный массив случайного числа от -10 до 10 подсчитать сумму…

Задание:

Дан двумерный массив случайного числа от -10 до 10 подсчитать сумму чисел которые находятся на диагоналях. Надо написать программу напишитекто-нибудь

Решение:

var a: array[1… 100, 1… 100] of integer; i, n, j, summ: integer; begin randomize; write ('n='); readln (n); writeln ('Исходный массив: '); for i: =1 to n do begin for j: =1 to n do begin a[i, j]: =random (21) — 10; write (a[i, j]: 4); end; writeln; end; summ: =0; for i: =1 to n do summ: =summ+a[i, i]+a[i, n — i+1]; if n mod 2=1 then summ: =summ — a[n div 2+1, n div 2+1]; writeln ('Summ=', summ); end.




Знаете другой ответ?

Отправить свой ответ