ТутРешу.Ру

Дано n чисел, сосчитать количество чисел, которые меньше -15…

Задание:

Дано n чисел, сосчитать количество чисел, которые меньше -15, найти сумму кратных 9, но не кратных 6. Пожалуйста, напишите программу для Pascal

Решение:

var a: integer; //a — вводимое число kol, s: integer; //kol — количество чисел, кратных 9, но не кратных 6; s — сумма чисел, которые меньше -15 i: integer; //Переменная для цикла n: word; begin n: =0; //Обнуляем счетчик s: =0; //Обнуляем сумму writeln ('Введите число n'); readln (n); //Вводим n for i: =1 to n do //Вводим число n раз begin writeln ('Введите целое число'); readln (a); if a < -15 then kol: =kol+1; //Если число < 15, то прибавляем к счетчику 1 if (a mod 9=0) and (a mod 6 <> 0) then s: =s+a; //Если число кратно 9, но не кратно 6, то прибавляем это число к сумме end; writeln ('Количество чисел, которые меньше -15: ', kol); {Выводим количество чисел и сумму} writeln ('Сумма чисел, кратных 9, но не кратных 6: ', s); end.




Знаете другой ответ?

Отправить свой ответ