Задание:
Написать программу в Pascal и составить ее блок — схему: по возрасту, введенному с клавиатуры, определить, к какой возрастной группе относится человек: от 0 до 7 лет дошкольник. От 8 до 17 лет школьник, от 18 до 23 лет студент, 24-55 лет работник, от 56 лет и старше пенсионер.
Решение:
var a: integer; begin write ('Введите возраст '); readln (a); write ('Этот человек '); case a of 0… 7: writeln ('дошкольник'); 8… 17: writeln ('школьник'); 18… 23: writeln ('студент'); 24… 55: writeln ('работник'); else writeln ('пенсионер'); end; end.
Знаете другой ответ?