ТутРешу.Ру

Напишите программу вычисления наибольшего общего делителя двух целых…

Задание:

Напишите программу вычисления наибольшего общего делителя двух целых чисел. А) с оператором repeat б) с оператором while (в интернетенеправильно) помогите пожалуйста

Решение:

var a,b: integer; begin readln (a,b); repeat if (a>b) then a: =a-b; if (b>a) then b: =b-a; until (a<>b); writeln ('gcd=', a); end. var a,b: integer; begin readln (a,b); while (a<>b) do begin if (a>b) then a: =a-b; if (b>a) then b: =b-a; end; writeln ('gcd=', a); end.




Знаете другой ответ?

Отправить свой ответ