Задание:
Pascal ABC. Составьте программу, которая рисует деталь в виде кольца внешним радиусом 150 и внутренним радиусом 50, в котором вырезаны отверстиярадиусом 30. Их центры находятся на расстоянии 100 от центра кольца (число отверстий n вводится с клавиатуры). 2
Решение:
Program grapho; uses crt,graphABC; var xc,yc,r1,r2,rc,ro,n,i,x,y: integer; a: real; beginrepeatwrite ('Количество отверстий от 3 до 7 n='); read (n); until n in [3… 7]; clrscr; hidecursor; xc: =windowwidth div 2; yc: =windowheight div 2; r1: =50; r2: =150; rc: =100; ro: =30; a: =2*pi/n; circle (xc,yc,r2); circle (xc,yc,r1); for i: =1 to n do begin x: =xc+round (rc*cos (a*i); y: =yc-round (rc*sin (a*i); circle (x,y,ro); end; end.
Знаете другой ответ?