ТутРешу.Ру

Подскажите как решить

Задание:

Подскажите как решить. Одновремный массв, состоящий из n положительных и отрицательных элементов, заполняется случайным образом. Составить программу, реализующую поиск первого отрицательного элемента и меняющую его с местами с последним элементом массива. Вывести результат на экран.

Решение:

const z=10; var a: array[1… z] of integer; i, n, tmp: integer; begin for i: =1 to z do begin a[i]: =random (6) — 4; write (a[i], '); end; writeln; for i: =1 to z do begin if (a[i] < 0) and (n=0) then begin tmp: =a[z]; a[z]: =a[i]; a[i]: =tmp; inc (n); end; write (a[i], '); end; end.




Знаете другой ответ?

Отправить свой ответ