ТутРешу.Ру

Помогите! Очень срочно нужно!

Задание:

Помогите! Очень срочно нужно! Составить программу нахождения наибольшего элемента в линейном массиве, используя вспомогательные процедурынахождения наибольшего из двух чисел и создания массива случайных чисел. Началосоздание массива Tablz: =a[1]i: =2,n Max (z, a[i],z) вывод Max конец

Решение:

Например так: program test; uses crt; var arr: array[1… 20] of integer; max,i: integer; function smax (n1,n2: integer): integer; begin if n1>n2 then smax: =n1 else smax: =n2; end; begin clrscr; randomize; for i: =1 to 20 do begin arr[i]: =random (90)+10; write (arr[i],'); end; max: =arr[1]; for i: =1 to 20 do max: =smax (max,arr[i]); writeln; writeln (max); end.




Знаете другой ответ?

Отправить свой ответ