ТутРешу.Ру

Помогите пожалуйста написать программу по паскалю- дана квадратная…

Задание:

Помогите пожалуйста написать программу по паскалю- дана квадратная матрица A порядка M найти среднее арифметическое элемента каждой ее диагоналипараллельной побочной

Решение:

var a: array [1… 100,1… 100] of integer; b: array[1… 201,1… 2] of real; i,j,k,m: integer; Begin read (m); {vvod matricy A} for i: =1 to m do for j: =1 to m do begin b[i+j-1,1]: =b[i+j-1,1]+a[i,j]; b[i+j-1,2]: =b[i+j-1,2]+1; end; for i: =1 to 2*m-1 do writeln (b[i,1]/b[i,2]); End.




Знаете другой ответ?

Отправить свой ответ