Задание:
Помогите решить задачу на Паскале. Для заданного одномерного МАССИВА с компонентами вещественного типа написать программу решениязадачи: вычислить среднее арифметическое его положительных членов.
Решение:
const n=10var a: array[1… n] of real; summ: real; i, n, count: integer; begin count: =0; summ: =0; for i: =1 to n do begin a[i]: =(random (101) — 50) / 10; write (a[i], '); if a[i] > 0 then begin summ: =summ+a[i]; inc (count); end; end; writeln; writeln ('Среднее арифметическое: ', summ / count); end.
Знаете другой ответ?