ТутРешу.Ру

Последовательно вводятся количества пассажиров которые едут в каждом…

Задание:

Последовательно вводятся количества пассажиров которые едут в каждом из N одинаковых вагонов поезда. Написать программу которая выдавала бы номеравагонов в которых наибольшее количество свободных мест. Ввод коректен.

Решение:

PASCAL for i: =1 to 7 do mas[i]: =read (x); min: =mas[1]; for i: =1 to 7 do begin if min > mas[i] then begin min: =mas[i]; end; end; writeln (min); Массивы и переменные не стал объявлять ибо сами сможете наверникаСначала заполняем массив, потом минимальное число — певый индекс массива если это число оказывается больше какого-то то мы присваевыем переменной min это число.




Знаете другой ответ?

Отправить свой ответ