ТутРешу.Ру

Ребят, помогите пожалуйста…

Задание:

Ребят, помогите пожалуйста, ибо меня завтра учитель информтики пристрелит. Составить программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:

Решение:

Код Pascal1234567891011121314151617181920212223242526272829303132333435363738394041var m: array[1… 40]of integer; i: byte; a,ka,b,c: integer; begina: =0; ka: =0; //задание Аb: =0; //задание Бc: =0; //задание В for i: =1 to 40 dobegin m[i]: =random (21); if m[i] mod 2<>0 then begin ka: =ka+1; a: =a+m[i]; end; if m[i] <= 10 then b: =b+m[i]; if m[i] mod 3=0 then c: =c+m[i]; end; for i: =1 to 40 do if i=1 then write ('M[',m[i],',') else if i=40 then writeln (m[i],']') else write (m[i],','); if ka=0 then ka: =1; writeln; writeln ('Среднее арифметическое нечетных чисел=',a/ka); writeln ('Сумма чисел не превышающих 10=',b); writeln ('Сумма чисел, кратных 3=',c); end.




Знаете другой ответ?

Отправить свой ответ