Задание:
Составить программу на языке Паскаль числа по возрастанию.
Решение:
program parampampam; uses crt; var i: integer; {счетчик} s: integer; begin clrscr; {очистка экрана} writeln ('Программа выводит числа от 1 до 99, сумма цифр которых равна числу S'); writeln ('Введите число S, от 0 до 18: '); {ввод числа S с проверкой на корректность} repeat readln (s); if (s>18) or (s<0) then writeln ('Неверный ввод. Повторите') until (s <= 18) and (s>=0); {вывод нужных чисел на экран (цикл с предусловием) } for i: =1 to 99 do if (i div 10)+(i mod 10)=s) then {div дает целую часть, mod — остаток от деления} write (i, '); repeat until keypressed; {пустой цикл для задержки экрана до нажатия клавиши} end.
Знаете другой ответ?