ТутРешу.Ру

Составить программу в паскале для 8 класса, без array пожалуйста…

Задание:

Составить программу в паскале для 8 класса, без array пожалуйста, задача: найти кол-во четных цифр числа, тема — разработка алгоритма содержащего цикл сусловием, тоесть с while, do, begin ну тоесть их испобьзовать, вот так составить программу по задаче

Решение:

Самое простое что придумал) uses crt; vari,a,s: integer; beginwrite ('vvedite 4islo: '); read (a); s: =0; while a>=1 dobegini: =a mod 10; a: =a div 10; if i mod 2=0 thens: =s+1; end; write ('kolvo 4etnblx=',s); read; end. Смысл программы: делит число на 10 и проверят четный остаток или нет, и следовательно четная это была цифра или нет)




Знаете другой ответ?

Отправить свой ответ