ТутРешу.Ру

Составьте программу, которая формирует массив из 40 случайных чисел…

Задание:

Составьте программу, которая формирует массив из 40 случайных чисел от 0 до 20 ивычисляет: а) среднее арифметическое нечетных чиселб) сумму чисел, не превышающих 10 в) сумму чисел, кратных 3На экран выводятся исходные значения и результаты вычислений. Только а, б и в нужно написать как отдельные задачи, а не как одна. Пожалуйста, помогите. Очень срочно, завтра сдавать!

Решение:

A) program a1; uses crt; var m: array[1… 40]of integer; i: byte; a,ka: integer; beginclrscr; a: =0; ka: =0; for i: =1 to 40 dobegin m[i]: =random (21); if m[i] mod 2<>0 then begin ka: =ka+1; a: =a+m[i]; end; end; for i: =1 to 40 do if i=1 then write ('M[',m[i],',') else if i=40 then writeln (m[i],']') else write (m[i],','); writeln ('Среднее арифметическое нечетных чисел=',a/ka); end.b) program b1; uses crt; var m: array[1… 40]of integer; i: byte; b: integer; beginclrscr; for i: =1 to 40 dobegin m[i]: =random (21); begin if m[i] <= 10 then b: =b+m[i]; end; end; for i: =1 to 40 do if i=1 then write ('M[',m[i],',') else if i=40 then writeln (m[i],']') else write (m[i],','); writeln ('Сумма чисел не превышающих 10=',b); end. В) program v1; uses crt; var m: array[1… 40]of integer; i: byte; c: integer; beginclrscr; for i: =1 to 40 dobegin m[i]: =random (21); beginif m[i] mod 3=0 then c: =c+m[i]; end; end; for i: =1 to 40 do if i=1 then write ('M[',m[i],',') else if i=40 then writeln (m[i],']') elsewrite (m[i],','); writeln ('Сумма чисел кратных 3=',c); end.




Знаете другой ответ?

Отправить свой ответ