ТутРешу.Ру

Составьте программу на языке Паскаль для решения квадратного…

Задание:

Составьте программу на языке Паскаль для решения квадратного уравнения. Коэффициенты a,b и c вводятся с клавиатуры. На экране выводится информация означении корней квадратного уравнения.

Решение:

program yrav; var a,b,c,d,x1,x2,x: real; begin writeln ('Введите коэффиценты квадратного уравнения'); readln (a,b,c); d: =b*b-4*a*c; if d<0 then writeln ('корней нет'); if (d>0) and (a<>0) and (b<>0) and (c<>0) then begin x1: =(-b+sqrt (d) / (2*a); x2: =(-b-sqrt (d) / (2*a); writeln ('X1=',x1:6:3,' X2=',x2:6:3); end; if (a=0) and (b<>0) and (c<>0) then begin x=-c/b; writeln ('Один корень уравнения Х=',x: 6:3); end; if (b=0) and (c<0) and (a<>0) then begin x1=sqrt (-c/a); x2=-sqrt (-c/a); writeln ('X1=',x1:6:3,' X2=' ,x2:6:3); end else writeln ('Корней нет! '); if (a<>0) and (b<>0) and (c=0) then begin x1: =0; x2: =-b/a; writeln ('X1=', x1:6:3,' X2=',x2:6:3); end; end.




Знаете другой ответ?

Отправить свой ответ