ТутРешу.Ру

Составьте программу, определяющую…

Задание:

Составьте программу, определяющую, лежит ли точка с указанными координатами X, Y на окружности радиуса R с центром в начале координат.Program Frankenstein; varx,y,r: integer; Begin Write ('Введите координату X: '); Readln (x); Write ('Введите координату Y: '); Readln (y); Write ('Введите длину радиуса R: '); Readln (r); If (sqr (x)+sqr (y)=rthen writeln ('Точка лежит на окружности! ') Else writeln ('Точка не лежит на окружности! '); End. Почему программа всегда показывает что точка не лежит на окружности, хотя на самом деле она лежит! Где я ошибся?

Решение:

Varx,y,r: integer; BeginWrite ('Введите координату X: '); Readln (x); Write ('Введите координату Y: '); Readln (y); Write ('Введите длину радиуса R: '); Readln (r); If (sqr (x)+sqr (y)=sqr (r) then writeln ('Точка лежит на окружности! ') Else writeln ('Точка не лежит на окружности! '); End.




Знаете другой ответ?

Отправить свой ответ

…reshu.ru запрашивает разрешение на:
Показ уведомлений
Блокировать
Разрешить