90

1. Составить программу…

crediz 08 марта 2025

1. Составить программу, которая увеличивает каждый элемент настоящей таблице х [1 … 10] на 1. 2. Составить программу, замены положительныхэлементов настоящей таблице х [1 … 10] на 0.

категория: информатика

47

//первая программа var x: array[1… 10] of integer; i: integer; begin for i: =1 to 10 do begin write ('x[', i, ']='); readln (x[i]); inc (x[i]); end; writeln; writeln ('Result'); for i: =1 to 10 do write (x[i], '); readln; end. //вторая программа var x: array[1… 10] of integer; i: integer; begin for i: =1 to 10 do begin write ('x[', i, ']='); readln (x[i]); if x[i] > 0 then x[i]: =0; end; writeln; writeln ('Result'); for i: =1 to 10 do write (x[i], '); readln; end. // третья программа var x: array[1… 10] of integer; i: integer; begin for i: =1 to 10 do begin write ('x[', i, ']='); readln (x[i]); if x[i] < 0 then x[i]: =x[i]*x[i]; end; writeln; writeln ('Result'); for i: =1 to 10 do write (x[i], '); readln; end. // четвертая программа var x: array[1… 10] of integer; i: integer; begin for i: =1 to 10 do begin write ('x[', i, ']='); readln (x[i]); if x[i] > 10 then x[i]: =x[i]+2; end; writeln; writeln ('Result'); for i: =1 to 10 do write (x[i], '); readln; end.

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

ПОПУЛЯРНОЕ
skinner2009, 08 марта 2025
Дано натуральное чсло…
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...