60

1 Составить программу на языке Паскаль

ripway 07 марта 2025

1 Составить программу на языке Паскаль. Написать программу, заносящую в файл массив из 7 вещественных чисел, введенных с клавиатуры, а потом считывающуюэтот массив и выводящую на экран количество отрицательных элементов. Если таких нет, то выдать об этом сообщение.

категория: информатика

40

1) var f: text; a: array[1… 7] of real; i,k,c,x: integer; s: string; begin for i: =1 to 7 do begin readln (x); a[i]: =x; end; assign (f,'file.txt'); rewrite (f); for i: =1 to 7 do begin str (a[i],s); writeln (f,s); end; close (f); reset (f); k: =0; while not eof (f) do begin readln (f,s); val (s,x,c); if x<0 then k: =k+1; end; close (f); if k<>0 then writeln ('В массиве ',k,' отрицательных элемента (ов) '); else writeln ('В массиве нет отрицательных элементов'); erase (f); end.2) Var a,b,c,d: integer; Function max (a,b: integer): integer; begin if a>b then max: =a else max: =b; end; Begin readln (a,b,c,d); a: =(max (a,b); b: =(max (c,d); writeln ('max=',max (a,b); End.

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...