34

1. Составить программу вывода на экран всех трехзначных чисел…

dimaliss 25 февраля 2025

1. Составить программу вывода на экран всех трехзначных чисел, кратных 9. (паскаль, тремя способами) 2. Составить программу вычисления суммы всехтрехзначных чисел, кратных 17. (паскаль, тремя способами)

категория: информатика

42

1) Program Pr1; uses crt; var mas: array[100… 999] of integer; i: integer; Beginclrscr; for i: =100 to 999 do mas[i]: =i; {1 sposob}for i: =100 to 999 do if mas[i] mod 9=0 then writeln (mas[i]); i: =100; {2 sposob}while i <= 999 do begin if mas[i] mod 9=0 then writeln (mas[i]); i: =i+1; end; i: =100; {3 sposob}repeatif mas[i] mod 9=0 then writeln (mas[i]); i: =i+1until i=999end.2) Program Pr1; uses crt; var mas: array[100… 999] of integer; i,v: integer; Beginclrscr; v: =0; for i: =100 to 999 do mas[i]: =i; {1 sposob}for i: =100 to 999 do if mas[i] mod 17=0 then v: =v+mas[i]; writeln (v); i: =100; {2 sposob}v: =0; while i <= 999 do begin if mas[i] mod 17=0 then v: =v+mas[i]; i: =i+1; end; writeln (v); i: =100; {3 sposob}v: =0; repeatif mas[i] mod 17=0 then v: =v+mas[i]; i: =i+1until i=999; writeln (v); end.

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...