41

ИНФОРМАТИКА! Написать программу определения числа билетов…

kilobucks 07 января 2025

ИНФОРМАТИКА! Написать программу определения числа билетов с 6-значными номерами, у которых сумма первых 3 десятичных цифр равна сумме 3 последних десятичных цифр (ПАСКАЛЬ)

категория: информатика

41

Program BB; uses crt; Var s,a,b,v,z,i: longint; Begins: =1; {учитываем билет с номером 000000}for i: =1 to 999999 do {перебираем билеты от 000001 до 999999}begin v: =i; z: =0; while z<3 do begin z: =z+1; a: =v mod 10+a; v: =v div 10 end; {считаем сумму последних трех чисел} while z<6 do begin z: =z+1; b: =v mod 10+b; v: =v div 10 end; {считаем сумму первых трех чисел} if a=b then s: =s+1; a: =0; b: =0; end; writeln (s); ReadKey; end.

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

ПОПУЛЯРНОЕ
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...