66

Как написать программу которая напишет все целые числа…?

ender1974 09 марта 2023

Как написать программу которая напишет все целые числа от 1 до 50 которые кратны 9 и посчитает их произведение исумму

категория: информатика

95

Берем цикл от 1 до 50, идем и проверяем все числа на кратность 9, если кратны, то пишем число и добавляем к сумме (и умножаем произведение). var sum, mul, i: integer; begin sum: =0; mul: =1; for i: =1 to 50 do if i mod 9=0 then begin write (i, '); sum: =sum+i; mul: =mul*i; end; writeln; writeln ('sum=', sum); writeln ('mul=', mul); end.

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

ПОПУЛЯРНОЕ
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...