48

Написать программу, которая проверяет…

mentos 14 февраля 2023

Написать программу, которая проверяет, является ли введенная с клавиатуры строка двоичным числом. Помогите. НаPASCAL

категория: информатика

60

VAR c: Char; BEGIN Assign (input, 'input.txt'); ReSet (input); Read (c); If (c <> '1') then begin Write ('NO'); Exit; End; While (not eoln (input) do begin Read (c); If (c <> '0') and (c <> '1') then begin Write ('NO'); Exit; End; END.

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...