79

Написать программу ввода целых чисел до тех пор…

mazahaka 09 марта 2023

Написать программу ввода целых чисел до тех пор, пока не будет введен ноль, посчитать сумму введеных чисел и их среднее арифметическое. Помогитепожалуйста!

категория: информатика

73

var sum,n,temp: integer; begin sum: =0; n: =0; readln (temp); while (temp<>0) do begin inc (n); sum: =sum+temp; readln (temp); end; writeln ('Sum=',sum,'; Ave=',sum/n) end.

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

ПОПУЛЯРНОЕ
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...