55

Написать программу Вводя числа с клавиатуры без ограничения…

lankcaster 10 марта 2025

Написать программу Вводя числа с клавиатуры без ограничения их количества (конец ввода — число 0), найти сумму положительных и произведениеотрицательных чисел. СРОЧНО.

категория: информатика

49

program c1; var a,b,n: longint; Begin a: =0; writeln ('Вводи числа sergei1906'); repeat read (n); if n>0 then b: =b+n; if n<0 then a: =a*n; until n=0; Writeln ('Сумма положительных чисел: ',b); Writeln ('Произведение отрицательных чисел: ',a); End.

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

ПОПУЛЯРНОЕ
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...