48

НУЖНО К ЗАВТРАШНЕМУ ДНЮ!

geradot79 06 октября 2024

НУЖНО К ЗАВТРАШНЕМУ ДНЮ! Написать программу в Паскале общей формы решения квадратного уравнения.

категория: информатика

59

program kvur; uses crt; var a,b,c,x1,x2,d: real; begin write ('Введите первый коэффииент, a='); readln (a); write ('Введите второй коэффииент, b='); readln (b); write ('Введите свободный член, c='); readln (c); ///////решение d: =sqr (b) — (4*a*c); writeln ('D=',d); if d>0 thenbegin x1: =(-1)*b+sqrt (d) / (2*a); x2: =(-1)*b-sqrt (d) / (2*a); writeln ('Ответ: x=',x1,'; ',x2); end; if d=0 thenbegin x1: =(-1)*b/ (2*a); writeln ('Ответ: x=',x1); end; if d<0 then writeln ('нет решений'); end.

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...