36

Нужно написать программу в паскале. Срочно, помогите пожалуйста

hameleon 22 февраля 2025

Нужно написать программу в паскале. Срочно, помогите пожалуйста. Дан массив с температурам за январь от -35 до 35. Определить самый теплый день, дни, когдатемпература была больше нуля.

категория: информатика

45

var a: array[1… 31] of integer; i, index: integer; begin randomize; index: =1; writeln ('Температура по дням: '); for i: =1 to 31 do begin a[i]: =random (71) — 35; writeln ('a[', i, ']=',a[i]); if a[i] > a[index] then index: =i; end; writeln; writeln ('Самы теплый день — ', index, ' ,t=', a[index]); writeln ('Дени в котрых температура была > 0'); for i: =1 to 31 do if a[i] > 0 then write (i, '); readln; end.

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

ПОПУЛЯРНОЕ
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...