70

Помогите написать программу которая вычисляет сумму положительных…

boresh 09 марта 2025

Помогите написать программу которая вычисляет сумму положительных из n введенных с клавиатуры целых чисел (FOR) В паскалеABC

категория: информатика

84

program z1Начало программы) var n, s, i, c: integerРаздел описания переменных, n (кол-во чисел) , s (сумма чисел) , i (счетчик), с (число, введенное с клавиатуры) begin (тело программы) writeln ('Кол-во чисел? ') подсказка для пользавателя) readln (n) считывание переменной) s: =0 обнуляем переменную) For i: =1 to n do begin (цикл будет повторяться от 1 до N; т. К в цикле будет несколько действий открываем операторные скобки (begin\end), начало цикла) writeln ('Введите число') подсказка для пользавателя) readln (c) считывание переменной) If c>0 then s: =s+cесли с>0 тогда к сумме мы прибавляем число) endконец цикла) writeln ('Сумма=',s) подсказка для пользавателя и ответ) readln (s) считывание переменной) readlnсчитывание) end. (конец программы)

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...