46

Помогите пожалуйста решить задачки в паскале.1

maukji 15 февраля 2025

Помогите пожалуйста решить задачки в паскале.1. В одномерном массиве перенести элемент, стоящий на первом месте в конец массива.2. Вывести на печать номера точек, лежащих в круге радиусом r. Координаты точек заданы массивами (x1,x2,… ,x10) , (y1,y2,… ,y10).3. В одномерном массиве найти сумму положительных, произведение отрицательных, количество четных элементов.4. Дан массив, состоящий из 50 элементов, найти предпоследний нечетнный элемент.

категория: информатика

44

1. Пишу не весь код, а только самую важную частьbuf: =a[1]; //buf имеет тип такой же, как и массивfor i: =1 to n-1 do a[i]: =a[i+1]; //сдвигаем все элементы влевоa[n]: =buf; // последнему присваиваем первый 2. if sqrt (sqr (x[i])+sqr (y[i]) <= R then writeln (x[i],',y[i]) 3. Опять же не весь кодch// Кол-во четныхp// Произведениеs// Суммаs: =0; ch: =0; p: =1; for i: =1 to n do begin if a[i]>=0 then s: =s+a[i]else p: =p*a[i]; if a[i] mod 2=0 then ch: =ch+1; end; writeln ('Четных ', ch); writeln ('Сумма положительных ', s); writeln ('Произведение отриц ', p); P.S. Не компилировал, но должно работать.

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

ПОПУЛЯРНОЕ
uglik, 15 февраля 2025
1. Составьте программу…
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...