50

Помогите пожалуйста срочно. Pascal…

balyuoleg 02 февраля 2025

Помогите пожалуйста срочно. Pascal 1. Проверить, что в массиве все элементы положительны. 2. Проверить, что все элементы массива равны друг другу. 3. Проверить, есть ли в массиве элемент, равный заданному значению

категория: информатика

76

var a: array [1… 100] of real; n, i: integer; begin read (n); for i: =1 to n do read (a[i]); for i: =1 to n do if a[i] <= 0 then begin writeln ('NO'); readln; Halt; end; writeln ('YES'); readln; end. var a: array [1… 100] of real; n, i: integer; o: real; begin read (n); for i: =1 to n do read (a[i]); o: =a[1]; for i: =2 to n do if a[i] <> o then begin writeln ('NO'); readln; Halt; end; writeln ('YES'); readln; end. var a: array [1… 100] of real; n, i: integer; x: real; begin read (n); for i: =1 to n do read (a[i]); read (x); for i: =1 to n do if a[i]=x then begin writeln ('YES'); readln; Halt; end; writeln ('NO'); readln; end.

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике
02 февраля 2025
Очень прошу помогите с Паскалем!) 1. Напишите программу, вычисляющую площадь прямоугольника. С клавиатуры вводятся два действительных числа – стороны прямоугольника. Необходимо вычислить его площадь и вывести на экран. Вывод должен быть отформатирован следующим образом: под число отводится 10 знаков, а под вещественную часть – 3. 2. С клавиатуры вводятся 3 целых числа. Определить количество положительных чисел в этом наборе. 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число n. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число n. Посчитайте сумму S=1+2+… +n. 6. Даны целые положительные числа N и K. Используя только операции сложения и вычитания, найти частное от деления нацело N на K, а также остаток от этого деления. 7. С клавиатуры вводится натуральное число N. За ним последовательно вводятся данные о росте N учащихся класса. Определите средний рост учащихся всего класса. Попробуйте решить эту задачу без использования массивов. 8. Заполнить элементы массива последовательностью чисел: 2, 5, 10, 17, 26, … 9. Вводится число N, а за ним N целых чисел – элементов массива. Найдите количество отрицательных элементов в этом массиве. 10. С клавиатуры вводится число N. Выведите следующую фигуру (N-строк, на последней строке N звездочек). Подсказка: для решения этой задачи примените конструкцию «цикл в цикле» .*… *11. Массив заполняется целыми числами до «нуля». Замените все положительные числа массив на противоположные им, а отрицательные возведите в квадрат. Выведите изменившийся массив. 12. На вход программе поступает целое число N. Выведите количество делителей N, включая 1 и само число N. Внимание: для решения этой задачи заведите счетчик и не забудьте сначала занести в него значение 0.

Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...