41

Пожалуйста, помогите решить задачи по информатике (паскаль):…

kulak-a 13 февраля 2025

Пожалуйста, помогите решить задачи по информатике (паскаль): 1. Ввести два числа. Будет ли их сумма меньше 40? 2. Даны 20 пар чисел. В скольких парах первое число больше второго?

категория: информатика

95

1) var a, b: integer; begin read (a, b); if a+b<40 then write ('YES') else write ('NO'); end.2) var i, a, b, k: integer; begin for i: =1 to 20 do begin read (a, b); if a>b then inc (k); end; writeln (k); end.

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике
13 февраля 2025
1. В одном из вариантов кодировки Unicode каждый символ кодируется 16 битами. Определите информационный объем сообщения из 512 символов в этойкодировке 1) 512 байт 2) 1024 бит 3) 512 бит 4) 1 Кбайт 2. В одном из вариантов кодировки Unicode каждый символ кодируется двумя байтами. Определите количество символов в сообщении, если информационный объем сообщения в этой кодировке равен 480 бит.1) 60 2) 40 3) 240 4) 30 3. Информационный объем сообщения, содержащего 2048 символов, составляет 2 Кбайта. Каким количеством бит кодируется каждый символ этого сообщения? 1) 32 2) 16 3) 8 4) 4 4. В кодировке КОИ-8 каждый символ кодируется одним байтом. Определите информационный объем следующего сообщения в этой кодировке: Вода и землю, и камень точит. 1) 216 байт 2) 24 байта 3) 232 бит 4) 184 бит 5. Статья, набранная на компьютере, содержит 16 страниц, на каждой странице 35 строк, в каждой строке 64 символа. Определите информационный объем статьи в кодировке КОИ-8, в которой каждый символ кодируется 8 битами.1) 35 Кбайт 2) 70 Кбайт 3) 280 байт 4) 35840 бит 6. Текст содержит некоторое количество страниц, на каждой из которых 64 строки по 16 символов. Сколько страниц в тексте, если известно, что информационный вес текста составляет 6 Кбайт, а каждый символ текста кодируется двумя байтами? 1) 48 2) 3 3) 6 3) 12 7. Текст содержит 12 страниц, на каждой из которых 16 строк по несколько символов в каждой. Сколько символов в каждой строке, если известно, что информационный вес текста составляет 18 Кбайт, а каждый символ текста кодируется двумя байтами? 1) 768 2) 24 3) 48 4) 96 8. Текст содержит 8 страниц, на каждой из которых расположены строки по 25 символов в каждой. Сколько строк на каждой странице, если известно, что информационный вес текста составляет 25 Кбайт, а каждый символ текста кодируется восьмью битами? 1) 128 2) 64 3) 32 4) 64 9. В одном из вариантов кодировки Unicode каждый символ кодируется 16 битами. Определите информационный объем сообщения из 256 символов в этой кодировке 1) 256 байт 2) 512 бит 3) 256 бит 4) 512 байт 10. В кодировке КОИ-8 каждый символ кодируется одним байтом. Определите количество символов в сообщении, если информационный объем сообщения в этой кодировке равен 160 бит.1) 10 2) 16 3) 20 4) 160 11. Информационное сообщении объемом 1,5 Кбайта содержит 3072 символа. Каким количеством бит кодируется каждый символ этого сообщения? 1) 32 2) 4 3) 8 4) 16 12. В одном из вариантов кодировки Unicode каждый символ кодируется 16 битами. Определите информационный объем сообщения в этой кодировке: Антология глупых мыслей – уже мудрость.1) 39 байт 2) 78 байт 3) 68 байт 4) 592 бит 13. Статья, набранная на компьютере, содержит 8 страниц, на каждой странице 40 строк, в каждой строке 64 символа. Определите информационный объем статьи в кодировке Unicode, в которой каждый символ кодируется 16 битами.1) 40 Кбайт 2) 320 байт 3) 35 Кбайт 4) 640 байт 14. Текст содержит некоторое количество страниц, на каждой из которых 128 строк по 64 символа. Сколько страниц в тексте, если известно, что информационный вес текста составляет 80 Кбайт, а каждый символ кодируется двумя байтами.1) 6 2) 10 3) 5 4) 15 15. Текст содержит 15 страниц, на каждой из которых 32 строки по несколько символов в каждой. Сколько символов в каждой строке, если известно, что информационный вес текста составляет 30 Кбайт, а каждый символ текста кодируется одним байтом? 1) 256 2) 512 3) 32 4) 64 16. Текст содержит 16 страниц, на каждой из которых расположены строки по 50 символов в каждой. Сколько строк на каждой странице, если известно, что информационный вес текста составляет 75 Кбайт, а каждый символ текста кодируется восьмью битами? 1) 48 2) 96 3) 192 4) 768 17. В алфавите 4 символа. Определите информационный объем сообщения из 40 символов в этой кодировке: 1) 10 байт 2) 10 бит 3) 160 бит 4) 40 байт 18. Считая, что сообщение, состоящее из 48 символов, занимает в памяти компьютера 12 байт, определите, сколько символов в используемом алфавите: 1) 2 3) 12 3) 24 4) 4 19. Определите количество символов в сообщении, если известно, что информационный объем сообщения, состоящего из символов алфавита мощностью 32, равен 25 байт.1) 40 2) 32 3) 25 4) 200 20. В алфавите 128 символов. Определите информационный объем сообщения из 32 символов в этой кодировке.1) 32 бита 2) 32 байта 3) 28 байт 4) 224 байт 21. Считая, что сообщение, состоящее из 24 символов, занимает в памяти компьютера 9 байт, определите, сколько символов в используемом алфавите: 1) 3 2) 8 3) 24 4) 72 22. Определите количество символов в сообщении, если известно, что информационный объем сообщения, состоящего из символов алфавита мощностью 8, равен 45 байт.1) 8 2) 45 3) 120 4) 360Кодом пожалуйста. Например 1-а и т. Д
13 февраля 2025

ПОПУЛЯРНОЕ
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...