33

ПОЖАЛУЙСТА! ПОМОГИТЕ! СРОЧНО!

shakal87 05 марта 2023

ПОЖАЛУЙСТА! ПОМОГИТЕ! СРОЧНО! Решить задачи на турбопаскале: ХОТЯБЫ ПАРУШТУК1. Дано натуральное число Найти сумму и произведение первых двух цифр.2. Дано n-значное натуральное число. Правда ли что квадрат произведения цифр числа равняется кубу суммы цифр числа.3. Составить программу, которая печатает таблицу умножения и сложения натуральных чисел в десятичной системе счисления.

категория: информатика

42

Program Kasyanova98_1; uses crt; var n,nt,p: integer; begin writeln ('*Alphaues is thinking… *'); write ('Ok, введите натуральное число N='); readln (n); nt: =n; while nt>=10 do begin p: =nt; nt: =nt div 10; end; writeln ('Cумма первых двух цифр числа ',n,' равна ', (p div 10)+(p mod 10); writeln ('Произведение первых двух цифр числа ',n,' равно ', (p div 10)*(p mod 10); end.Program Kasyanova98_2; uses crt; var n,nt,sum,kw,temp: integer; begin writeln ('*Alphaues is thinking… *'); write ('Ok, введите натуральное число N='); readln (n); nt: =n; sum: =0; kw: =1; while nt>=1 do begin temp: =nt mod 10; sum: =sum+temp; kw: =kw*temp; nt: =nt div 10; end; if kw*kw=sum*sum*sum then writeln ('Квадрат произведения цифр числа ',n,' равняется кубу суммы его цифр') elsewriteln ('Квадрат произведения цифр числа ',n,' НЕ равняется кубу суммы его цифр'); end.Program Kasyanova98_3,1; uses crt; const n=10; var x,y: integer; begin writeln ('*'); writeln ('*ТАБЛИЦА УМНОЖЕНИЯ*'); writeln ('*'); write ('*'); for y: =1 to n do begin write (y: 2); if y

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике
05 марта 2023
№1 Мощность алфавита равна 8 символов. В сообщении 20 символов. Какой его информационный объем? №2 Информационный объем сообщения 4096 бит содержит 1024 символа. Какова мощность алфавита, с помощью которого составлено это сообщение? №4 Какова мощность алфавита, с помощью которого записано сообщение, содержащее 4096 символов, если его объем составляет 1,5 Кбайта? № сколько символов содержит сообщение, записанное с помощью 16-ти символьного алфавита, если объем его составил 1/64 часть Мбайта? №6 Сообщение занимает 4 страницы по 30 строк. В каждой строке по 50 символов. Все сообщение содержит информации в 4500 байт. Какова мощность используемого алфавита? № 7 ДНК человека (генетический код) можно представить себе как некоторое слово в четырехбуквенном алфавите, где каж¬дой буквой помечается звено цепи ДНК, или нуклеотид. Сколько информации (в битах) содержит ДНК человека, содержащий примерно 1,5 х 1023 нуклеотидов?

Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...