41

Решите в тетради задачи, используя цикл while-wend…

zoozoo 04 сентября 2024

Решите в тетради задачи, используя цикл while-wend 1. Написать программу, вычисляющую сумму и среднее арифметическое последовательности положительныхчисел, которые вводятся с клавиатуры. 2. Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).

категория: информатика

68

using System; namespace Interesting { class Program { static void Main () { float Max=0; float Sum=0; float N=0; string s; float num; Console.WriteLine ("Введите последовательность чисел. Для окончания введите пустую строку"); try { while (true) { Console.WriteLine ("Введите число"); s=Console.ReadLine (); num=Convert.ToSingle (s); Max=(num > Max)? num: Max; Sum+=num; N+; } } catch (Exception e) { Console.WriteLine ("Ввод закончен"); } Console.WriteLine ("Максимальное={0}, Среднее={1}", Max, Sum / N); } }}

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

ПОПУЛЯРНОЕ
sany82, 04 сентября 2024
a: =1686; b: =(adiv10) mod 5; a: =a-200*b
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...