92

Составить программу, которая определяет сколько раз встречается…

lofant 01 марта 2023

Составить программу, которая определяет сколько раз встречается в таблице а максимальное по величинечисло.Pascal. Массивы. Помогите, пожалуйста

категория: информатика

49

const n=100; m=100; var A: array[1… n,1… m] of integer; i,j,maxi,maxj,k: integer; beginrandomize; for i: =1 to n do begin for j: =1 to m do begin A[i,j]: =random (100); end; end; maxi: =1; maxj: =1; for i: =1 to n do begin for j: =1 to m do begin if (A[i,j] > A[maxi,maxj]) then begin maxi: =i; maxj: =j; end; end; end; k: =0; for i: =1 to n do begin for j: =1 to m do begin if (A[i,j]=A[maxi,maxj]) then k: =k+1; end; end; writeln ('k=', k); end.

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

ПОПУЛЯРНОЕ
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...