60

Составить программу на языке Паскаля: Даны а,b,c-целые числа

shastliviy 06 марта 2023

Составить программу на языке Паскаля: Даны а,b,c-целые числа. Если они большн 0-вычислите сумму их квадратов; а если хотя бы одно из них четно-вычислите ихсумму и произведение.

категория: информатика

53

var a,b,c: integer; begin readln (a,b,c); if (a>0) and (b>0) and (c>0) then writeln (sqr (a)+sqr (b)+sqr (c); if (a mod 2=0) or (b mod 2=0) or (c mod 2=0) then writeln ('Сумма: ',a+b+c,', произведение: ',a*b*c); end.

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

ПОПУЛЯРНОЕ
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...