39

Составить программу удваивающую четные по номеру элементы массива…

compressor 01 марта 2025

Составить программу удваивающую четные по номеру элементы массива а нечетные по номеру уменьшитьвдвое … элементы произвольные. Тема одномерные массивы

категория: информатика

47

Вот решение. Надеюсь на отметку Лучший ответ.var m: array [1… 1000] of real; i,j: longint; begin read (j); for i: =1 to j do begin read (m[i]); if i mod 2=0 then m[i]: =m[i]*2 else m[i]: =m[i]/2; end; for i: =1 to j do write (m[i],'); end.

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

ПОПУЛЯРНОЕ
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...