48

Составьте программу выводящую на экран числа от 1 до 30 которые…

struva 07 сентября 2024

Составьте программу выводящую на экран числа от 1 до 30 которые делятся без остаткак на и на 3 но не делятся на 4

категория: информатика

51

Var a,b,c,n,i: integer; begin writeln ('На что должно делиться (2 числа через пробел) => '); readln (a,b); {делится на а и b но не делится на c} writeln ('На что не должно делиться (1 число) => '); readln (c); writeln ('Верхняя граница (1 число) => '); readln (n); for i: =1 to n do if (i mod a=0) and (i mod b=0) and (i mod c <> 0) then writeln (i); end.var i: integer; begin for i: =1 to 30 do if (i mod 2=0) and (i mod 3=0) and (i mod 4 <> 0) then writeln (i); end2) var i: integer; begin for i: =50 downto 1 do if (i mod 2 <> 0) then writeln (i); end.

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...