40

Строка S составлена из нескольких предложений…

tocaboca 15 марта 2025

Строка S составлена из нескольких предложений, каждоеиз которых заканчивается точкой, восклицательным или вопросительным знаком. Напишите программу, которая выводит на экран количество предложений в данной строке.

категория: информатика

70

function max (x,y: longint): longint; begin if x>y then max: =x else max: =y; end; var k: longint; s: string; begin readln (s); while (pos ('.',s) <>0) or (pos ('! ',s) <>0) or (pos ('? ',s) <>0) dobegin k: =k+1; Delete (s,max (max (pos ('.',s) ,pos ('! ',s) ,pos ('? ',s) ,1); end; writeln (k); end.

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...