84

Необходимо составить программу в Pascal — дискриминанта, где a…

otomo 08 марта 2025

Необходимо составить программу в Pascal — дискриминанта, где a, b и с задаются генератором случайных чисел, все это вмассиве

категория: информатика

45

var a: array[1… 3] of integer; {объявляем массив из 3-х элементов типа integer} i, D: integer; begin randomize; for i: =1 to 3 do a[i]: =random (21) — 10; {заполняем массив случайными числами от -10 до 10} D: =a[2]*a[2] — (4*a[1]*a[3]); {вычисляем дискриминант} writeln ('a=', a[1]); writeln ('b=', a[2]); writeln ('c=', a[3]); writeln; writeln ('D=', D); readln; end.

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

ПОПУЛЯРНОЕ
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...