87

ЗАДАЧА PASCAL СРОЧНО!

soliist 11 января 2025

ЗАДАЧА PASCAL СРОЧНО! Написать программу которая бы формировала массив из 10 элементов в диапазоне от-50 до 20. В массиве выделить минимальный и максимальный элемент. Упорядочить методом пузырька или методом выбора мин. Элемента. Пожалуйста! Очень срочно!

категория: информатика

47

Uses crt; const N=10; var a: array [1… N] of real; x,y: integer; min,max,k: real; begin writeln ('Исходный массив: '); for x: =1 to N do begin a[x]: =random (71) -50; write (a[x]: 5:0); end; min: =a[1]; max: =a[1]; for x: =1 to N do begin if a[x]max then max: =a[x]; end; {сортировка пузырьком} for x: =1 to N-1 do for y: =1 to N-x do if a[y]>a[y+1] then begin k: =a[y]; a[y]: =a[y+1]; a[y+1]: =k; end; writeln; writeln ('Отсортированный массив: '); for x: =1 to N do write (a[x]: 5:0); writeln; writeln ('Минимальный элемент: ',min,'; максимальный элемент: ',max); end.-Мне будет очень приятно, если отметишь лучшим мое решение

пользователи выбрали этот ответ лучшим

Знаете другой ответ?
Другие вопросы по информатике

Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее...